Strange problem with COM object

Hi everybody.

A quick question:

In the application I'm developing I have those two line of code:

e3App = Activator.CreateInstance(Type.GetTypeFromProgID("CT.Application")) as IApplicationInterface;
if (e3App != null)

 

In my notebook where I develop I have no problem but with the PC of the customer, the object e3App is null and so I get an error. Anyway,after the first row of code, E3 starts regulary...

What can be the problem?

Thanks

mm

0

Comments

4 comments
  • A small update.. The e3App object is really null.. I already tried to launch E3 with /register option but without any success...

    e3App = Activator.CreateInstance(Type.GetTypeFromProgID("CT.Application")) as IApplicationInterface

    Here the object e3App is null!!

    0
    Comment actions Permalink
  • I would submit this to Zuken Global Support.

    0
    Comment actions Permalink
  • Maybe the customer's PC does not have the correct Redistributable C++ or.NET package for whatever methods you're using.

    0
    Comment actions Permalink
  • Thanks to both for your replies. The solution was to upgrade the E3 from 19.00 to 19.3 (build 19.03).

    The very strange thing was that the older version of my application worked correctly using the same line of code:

    e3App = Activator.CreateInstance(Type.GetTypeFromProgID("CT.Application")) as IApplicationInterface

     

    And, obviously, "nothing" did change since that version (Visual Studio, C#, .NET 4.5, OS 64 bit and E3 32 bit, etc...)

    Maybe a Windows update changed something on my laptop... I don't know..

    @Bob: I talked with Zuken global Support (I think from Shanghai) and they did not know how to solve the issue.. And after my solution, they were surprised because from 19.00 to 19.3, the COM interface was not changed...

    0
    Comment actions Permalink

Please sign in to leave a comment.

Didn't find what you were looking for?

New post