What can we help you with today?

Chat with a service agent now! Check out our help button in the bottom right corner!

How to Manage NoDBE in E3-2017

Comments

6 comments

  • Avatar
    Paul Bloom

    I don't think you can permanently disable it through the registry.  I suppose you could force a workspace configuration on your users which removes the option to start the DBE.

    Can't you just manage the write permissions on your library?  That's what I do.

    0
    Comment actions Permalink
  • Avatar
    Khang Nguyen (Zuken)

    Hi Mohamed,

    You can add /nodbe to the E3 shortcut target and this will hide the Tools>Start Database Editor.

    "C:\Program Files (x86)\Zuken\E3.series_201X\E3.series.exe" /cable /nodbe

    Likewise, as Paul Bloom mentioned, you should set read-only permissions to the library for your users.

     

     

    0
    Comment actions Permalink
  • Avatar
    Mohamed Asharf Ali

    @Paul-my intention is to block the user to start DBE mode only(from the tools me nu as wellas from the right click on the db)
    @Khang Nguyen- nodbe on short cut is one of the option,but in our case we need to deploy this setting to more than 100 users at a time and infuture it is 450+, and for me it is easy that if an registry entry or any script do the task then for me it is easy to manage.

    0
    Comment actions Permalink
  • Avatar
    Khang Nguyen (Zuken)

    For mass deployment, you can consider writing a batch script to push the shortcut to:

    Start Menu:

    "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Zuken\E3.series 201X\"

     

    Desktop:

    C:\Users\Public\Desktop

    0
    Comment actions Permalink
  • Avatar
    Paul Bloom

    A "smart" user can always modify a shortcut.  If you do it with permissions, it doesn't even matter if they can start DBE; they couldn't do anything if they did.

    0
    Comment actions Permalink
  • Avatar
    Sanu Warrier

    I would agree with the suggestion from Paul - the best method is to make the database read only

    0
    Comment actions Permalink

Please sign in to leave a comment.